New TH30 question

Orange Amps Technical Q&A's

Moderator: bclaire

Post Reply
Lyric
Tiny Terror
Posts: 56
Joined: Wed May 10, 2017 2:23 am
Location: Knoxville, TN

New TH30 question

Post by Lyric » Sun Jan 03, 2021 7:51 pm

Hi everyone, it’s been awhile since I’ve been on here :)

Recently I finally picked up a Orange TH30 and I say finally as I’ve been wanting one for a long while lol. So I found a 2019 used in mint condition with factory inspection tags still attached lol. It looks brand new from factory, no scratches, dings or nothing. It sounds beautiful and I love it. It compliments my PRS Archon and other gear as well.

Anyways my question is when I went to check out the JJ EL84 power tubes I noticed two of the four had lost 80% of their red logo paint look but instead now look like a tan color. So the red JJ brand stamping is no longer red but tan colored. Amp works perfectly fine, no issues at all. The two tubes that have red still were on left side and the two faded tubes were on the right side. I assume sometimes tubes do loose emblem paint color and that this can be normal but I thought I’d ask others here.

I have ordered all new EL84 power tubes and all new 12ax7 + 12at7 pre amp tubes to give it a fresh new start. Is it wise to replace fuses as well, I assume they are perfectly fine as the amp works just perfect.
Last edited by Lyric on Sun Jan 03, 2021 7:58 pm, edited 1 time in total.
17' Taylor 814CE
10' Manuel Rodriguez Cocobolo
14' Fender Limited Edition LoneStar Strat
16' Fender Classic Player 60's Jazzmaster
15' Fender Classic Player Jaguar
17' Reverend Double Agent 20th Anniversary
04' Ibanez SA220

Orange CR120H/Crush Pro 4x12

Lyric
Tiny Terror
Posts: 56
Joined: Wed May 10, 2017 2:23 am
Location: Knoxville, TN

Re: New TH30 question

Post by Lyric » Sun Jan 03, 2021 7:54 pm

Tried to submit a pic but forum pic upload doesn’t work right lol

Anyways here’s a Flickr link to show pic of EL34 power tubes

https://flic.kr/p/2koKehi
17' Taylor 814CE
10' Manuel Rodriguez Cocobolo
14' Fender Limited Edition LoneStar Strat
16' Fender Classic Player 60's Jazzmaster
15' Fender Classic Player Jaguar
17' Reverend Double Agent 20th Anniversary
04' Ibanez SA220

Orange CR120H/Crush Pro 4x12

bclaire
Forum Moderator
Posts: 17785
Joined: Thu May 02, 2002 9:19 pm
Location: Outside Boston MA, USA
Contact:

Re: New TH30 question

Post by bclaire » Tue Jan 05, 2021 3:02 am

Pic upload has never worked!

That's pretty wild... looks like it changed color from heat - makes me want to go check mine!

Lyric
Tiny Terror
Posts: 56
Joined: Wed May 10, 2017 2:23 am
Location: Knoxville, TN

Re: New TH30 question

Post by Lyric » Tue Jan 05, 2021 6:38 am

bclaire wrote:
Tue Jan 05, 2021 3:02 am
Pic upload has never worked!

That's pretty wild... looks like it changed color from heat - makes me want to go check mine!
Haha, yeah after trying on three devices to upload I just gave up lol.

Yeah I’m just not sure if this is normal or does happen sometimes. Never seen this before. I’ve found a couple instances online but nothing with info about why. Some say it’s just the tubes are going bad and some say a batch of bad ink for label. I’m not really sure myself. I purchased the amp used but it’s in mint condition and so far no issues. I have ordered all new tubes so we’ll see how well that goes. I do have a return timeframe of 45 days if it craps out but I don’t believe it’s the amp myself.
17' Taylor 814CE
10' Manuel Rodriguez Cocobolo
14' Fender Limited Edition LoneStar Strat
16' Fender Classic Player 60's Jazzmaster
15' Fender Classic Player Jaguar
17' Reverend Double Agent 20th Anniversary
04' Ibanez SA220

Orange CR120H/Crush Pro 4x12

Jondog
Duke of Orange
Posts: 7157
Joined: Thu Aug 21, 2008 12:16 pm
Location: Ontario, Canada

Re: New TH30 question

Post by Jondog » Wed Jan 06, 2021 8:31 pm

I wouldn’t worry too much if the amp is working fine. Who knows where the tubes were before you had the amp. You could swap positions. Whats more important is that you don’t see red plating or arcing in the tube.
Image

Lyric
Tiny Terror
Posts: 56
Joined: Wed May 10, 2017 2:23 am
Location: Knoxville, TN

Re: New TH30 question

Post by Lyric » Wed Jan 06, 2021 11:25 pm

Jondog wrote:
Wed Jan 06, 2021 8:31 pm
I wouldn’t worry too much if the amp is working fine. Who knows where the tubes were before you had the amp. You could swap positions. Whats more important is that you don’t see red plating or arcing in the tube.
Hi, Thanks

I just received a little bit earlier new power tubes and preamp tubes. I figured I might as well give it a fresh start, kind of like buying a used car and giving it all new fluids so you know where your at lol.

New tubes are in and it’s running beautifully and no issues. Amp heads serial number puts it at being made in October 2019 so just slight a few months over a year old - very nice.

I was a little concerned over two of the four power tubes ink being faded but with a fresh new start I’ll be able to know and track everything better. Loving the amp so far and no complaints and hopefully it’ll last for years without issue. It compliments my PRS Archon 100 in a strange way and basically fills little gaps and does has its own sound going. Love it.
17' Taylor 814CE
10' Manuel Rodriguez Cocobolo
14' Fender Limited Edition LoneStar Strat
16' Fender Classic Player 60's Jazzmaster
15' Fender Classic Player Jaguar
17' Reverend Double Agent 20th Anniversary
04' Ibanez SA220

Orange CR120H/Crush Pro 4x12

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests