Tiny Terror Anniversary no sound

Orange Amps Technical Q&A's

Moderator: bclaire

Post Reply
prsplayer55
New Member
Posts: 2
Joined: Sun Jun 17, 2018 3:36 pm

Tiny Terror Anniversary no sound

Post by prsplayer55 » Sun Jun 17, 2018 3:46 pm

Hi Guy's
My beautiful Anniversary tiny terror has given up the ghost on me, would be grateful for any ideas! The fuse blew first, so I replaced that and following advice from Orange tech guy's I also replaced the power valves with a balanced set of JJ's.
The Green light comes on now, and the valves glow nicely, but not a dicky bird from the output. I plugged a different amp (Vox MV50) into the same set up and all worked fine, so its a problem with the amp. I checked the mains fuse and that fine so I'm stumped what could be the problem?

prsplayer55
New Member
Posts: 2
Joined: Sun Jun 17, 2018 3:36 pm

Re: Tiny Terror Anniversary no sound

Post by prsplayer55 » Sun Jun 17, 2018 4:07 pm

Further developments, the fuse had blown again. I replaced it but it blew straight away for the third time. So something is causing the fuse to blow

bclaire
Forum Moderator
Posts: 17650
Joined: Thu May 02, 2002 9:19 pm
Location: Outside Boston MA, USA
Contact:

Re: Tiny Terror Anniversary no sound

Post by bclaire » Sun Jun 17, 2018 5:29 pm

Amp tech time...

fiveightandten
Orange Master
Posts: 3845
Joined: Sat Apr 05, 2003 6:18 pm
Location: Connecticut, USA

Re: Tiny Terror Anniversary no sound

Post by fiveightandten » Mon Jun 18, 2018 12:56 am

Do not keep loading fuses into the amp if they are blowing. You can do more damage to the amp this way. As Billy said, it's tech time.

The most likely scenario is that you had a partially shorted tube in the amp that failed and took out one or more components in the amp. If the amp is popping fuses with trusted new tubes in it, it's time for someone with troubleshooting experience to get under the hood to find out why.

-Nick
Image
'71 GRO100 || '96 OR-80 || AD30 || '64 AC-50 || AC-30TBX || Hiwatt DR504 || HI-TONE HT30
LP Standard || LP Studio || LP Custom Lite || Ric 620 || Ric 360 || MIA Tele || SG 61 RI

langmurf
Rocker
Posts: 154
Joined: Mon Mar 25, 2013 2:18 am
Location: 35 miles NE of the ATL

Re: Tiny Terror Anniversary no sound

Post by langmurf » Fri Jul 27, 2018 4:19 am

I had a TTHW that was blowing fuses as fast as I could put new ones in. (Well, only tried one or two...)

Long story short, turned out to be a bad PI tube.
Orange Rocker 15 Combo, Orange Two Stroke
2007 Gibson Melody Maker; Cort Steinberger

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests