NAD gone bad. Orange Root Terror

Orange Amps Technical Q&A's

Moderator: bclaire

Post Reply
ypnos
New Member
Posts: 1
Joined: Sat Aug 25, 2018 9:20 pm

NAD gone bad. Orange Root Terror

Post by ypnos » Sat Aug 25, 2018 9:23 pm

Bought this amp for 350 euros, which is a great deal considering everything goes well.

The amp is a 15 watt beast. Delivers hard rock and desertlike tones, but in a really agressive manner.

Hooked it up yesterday first time, but.... The amp stopped working for like less than a second, for 3 or 4 times at the beggining, randomly, an then stopped doing it. Thought it was some not well connecte cable.

That was not the issue as it turned out. Today the amp was not usable. Continuous blackouts. :(

The amp is played in a band situation rehearsing, volume wise maxed out and gain around 4.

Has three preamp tubes, but two of fhem seem to glow inside the metallic socket that protects them. Could this be it? A failed preamp tube?

Also the tube that runs the effect loops seems not to be glowing too.

Need help

Image

Les Paul Lover
Duke of Orange
Posts: 6760
Joined: Tue Aug 18, 2009 9:08 am
Location: Derby, England

Re: NAD gone bad. Orange Root Terror

Post by Les Paul Lover » Sun Aug 26, 2018 10:46 am

Is the amp new or 2nd hand?

If new, I would contact the seller, if 2nd hand and you just received it, ibwould contact the seller and look to send it back to.... unless you already have spare valves to try out.

I assume you have tried different guitar cable, and are absolutely certain your speaker cable is good too?

Otherwise, beside changing all the valves, which may be the issue, there isn't a great deal you can do.
Ant

Orange Gear: RV50 MKI, R30, AD15, AD5, PPC212
Past Orange: Orange AD30TC Combo, Tiny Terror

Guitars: Gibson Les Paul Standard Faded, Vigier Expert Retro 54, Gibson SG 70s Tribute, Aria Pro II RS X80, G&L ASAT Special Tribute

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests