Terror Bass 1000

Orange Amps Technical Q&A's

Moderator: bclaire

Post Reply
mattsteady
New Member
Posts: 1
Joined: Tue Jan 17, 2017 1:40 am

Terror Bass 1000

Post by mattsteady » Tue Jan 17, 2017 1:48 am

Love my TBass but need help. Lately the amp warms up and plays fine for a short period of time then fades out to a fraction of its power. I replaced the preamp tubes and the problem remains. It is a powerful amperage that a weak power source may be an issue but it happens in several locations so not just the source. Thank you for any prudent help

u2mark
New Member
Posts: 1
Joined: Wed Apr 19, 2017 4:38 am

Re: Terror Bass 1000

Post by u2mark » Wed Apr 19, 2017 4:41 am

I'm having the same issue. Have you found the cause or a fix?

vaughan
New Member
Posts: 3
Joined: Tue Jul 19, 2016 8:49 pm

Re: Terror Bass 1000

Post by vaughan » Mon Aug 28, 2017 8:46 pm

Howdy!

I'm having the same issue as well. Have either of you found the root cause?

Thanks,
V

andrewhemans
New Member
Posts: 1
Joined: Wed Sep 13, 2017 9:28 pm

Re: Terror Bass 1000

Post by andrewhemans » Wed Sep 13, 2017 9:30 pm

Hi,

I'm having this same issue with my Bass Terror, has anyone found the cause?

Lionthatch
New Member
Posts: 1
Joined: Sun Sep 24, 2017 3:11 pm

Re: Terror Bass 1000

Post by Lionthatch » Sun Sep 24, 2017 3:27 pm

I have the same issue with my Tiny Terror 500. I excluded the following possible sources of the defect:

- Bass Guitar
- any cables whatsoever
- effects
- tubes
- settings
- tube warmup

My local tech service and repair says that they don't know the solution either. They could make a guess and switch a coil/inductor "between" power relay and circuit board (i am no expert on this matter) for 200€. Not sure if this pays off. Any ideas?

a.hun
Duke of Orange
Posts: 9738
Joined: Sat Jun 15, 2002 1:05 am
Location: Amsterdam, Hollandland.nl

Re: Terror Bass 1000

Post by a.hun » Wed Oct 04, 2017 3:14 pm

Has anybody actually contacted Orange on this? Maybe an idea??? :wink:

They are usually great at helping with any issues. I'd be interested to hear what they say...


Andy.
aNDyH. :wink:

Ever tried to outstare a mirror?

In the bathtub of history the truth is harder to hold than the soap, and much more difficult to find!

bassdrop
Orange Master
Posts: 2418
Joined: Thu Jul 08, 2004 9:00 pm
Location: USA

Re: Terror Bass 1000

Post by bassdrop » Wed Oct 04, 2017 7:10 pm

It may not apply, but I had a similar issue with my AD200B a few years ago. You may want to have your tech check if the power connection for the 12AX7 tubes is a Molex style connector as opposed to a soldered connection. If it is have him try clipping off the connector and soldering the connection for both of the tubes. These connectors can corrode internally and lose conductivity as they heat up.

In the case of my AD200B, it was the connectors for the power tubes that was the issue but I believe the tech replaced all of the connections with soldered joints (all 4 power tubes and the 3 preamp tubes). That may not be the issue here but it's worth a shot to find out. I do know that Ade Emsley mentioned in a NAMM interview recently that Orange is now moving away from all plastic connectors starting this year, so I believe it has been a known issue. As Andy mentions above, Orange may well already have some things for your tech to troubleshoot as well.
mmmmmm drop

Guthrie Matthews Method
http://www.guthriematthews.com" onclick="window.open(this.href);return false;

Modified Fender Custom Shop Jazz, Warmoth P/J clone,
Orange AD200 MkIII, Barefaced Compact

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests