rocker 30 noise when cranked. PLEASE HELP

Orange Amps Technical Q&A's

Moderator: bclaire

Post Reply
orangegigety1
New Member
Posts: 1
Joined: Wed Dec 09, 2009 10:29 am

rocker 30 noise when cranked. PLEASE HELP

Post by orangegigety1 » Thu Feb 18, 2010 12:41 pm

so i bought a rocker 30 used off of ebay. in it were 6ca7's.
so after giving the amp a look over i plugged it in and noticed that i had a noisy gain pot. fixed that with some spray. also noticed that when i have the gain fairly high and my dirty volume up anywhere past 4o clock it gives me really weird buzzez and sweeping sounds. is this normal? especially when messing with my volume knob on my guitar (and believe me its not the guitar, it works fine on all my other gear and in the studio) i mean when fully pushed do these make unpleasent noises or is something else wrong with it? my first instinct was to replace the tubes so i got myself some el34's and some 12ax7s and did it with the assumption that this was a self biasing head. as it seemed it still made these noises just a little different tone to it, figured it was the difference in the 6ca7 and the el34's because of the mear size difference. any help would be appreciated!!

in all honesty the volume on this amp really dosent budge after 12 o clock i figure its just pushing the tubes harder for mor clipping and overtones ect when maxed out, but i dont think i would really need to turn it up ever to full 5 o clock. it just bothers me to hear it cuz it makes me feel like maybe its a dried up capacitor or maybe even transformer issues.

i am very new to tube amps as ive only ever had one other (jmp mkII 50w) and i was too young to know what was going on other than it sounded good lol.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest