questions not been answered !

Orange Amps General Forum

Moderator: bclaire

Post Reply
sparky7083
New Member
Posts: 5
Joined: Mon Apr 23, 2018 7:56 pm

questions not been answered !

Post by sparky7083 » Thu May 14, 2020 5:55 pm

I have recently started looking through questions other users have listed, an to be honest I don't really see any of the problems been solved !
I have spoken to orange technical several times about the same problem, with the same amp.
Is it just an Orange policy that they cant/wont help the average joe to resolve issues they may have with there amps.
I've personally have tried to purchase schmatics, gain advise and reason with the advise....All to no avail.
In the end I've sound the amps as spares or repair....
The thing I find strange is that most other amp suppliers are more than helpful with schmatics and test points (fender, Marshall) to name a few.
Even though I've loved the amp until it goes faulty, I feel very disappointed with customer after service I never received !
I think its time to sell another faulty Orange amp as spares or repair,,,,as the price I'm been quoted by orange recommended service centres is way too high....and out prices the amp itself.....
Think i'll try a Marshall next time ! :| :| :|

Sooner
Orange Master
Posts: 1193
Joined: Thu Apr 25, 2002 6:16 pm
Location: USA-land

Re: questions not been answered !

Post by Sooner » Thu May 14, 2020 10:16 pm

This is probably the wrong forum to complain about Orange service. You might try their Facebook page or this forum: https://orangeampforum.com/index.php
Sooner
AD1512 Serial No. 001

Jondog
Duke of Orange
Posts: 7144
Joined: Thu Aug 21, 2008 12:16 pm
Location: Ontario, Canada

Re: questions not been answered !

Post by Jondog » Fri May 15, 2020 12:46 pm

Whats the problem
Image

bclaire
Forum Moderator
Posts: 17739
Joined: Thu May 02, 2002 9:19 pm
Location: Outside Boston MA, USA
Contact:

Re: questions not been answered !

Post by bclaire » Sat May 16, 2020 6:17 pm

sparky7083 wrote:
Thu May 14, 2020 5:55 pm
I have recently started looking through questions other users have listed, an to be honest I don't really see any of the problems been solved !
I have spoken to orange technical several times about the same problem, with the same amp.
Is it just an Orange policy that they cant/wont help the average joe to resolve issues they may have with there amps.
I've personally have tried to purchase schmatics, gain advise and reason with the advise....All to no avail.
In the end I've sound the amps as spares or repair....
The thing I find strange is that most other amp suppliers are more than helpful with schmatics and test points (fender, Marshall) to name a few.
Even though I've loved the amp until it goes faulty, I feel very disappointed with customer after service I never received !
I think its time to sell another faulty Orange amp as spares or repair,,,,as the price I'm been quoted by orange recommended service centres is way too high....and out prices the amp itself.....
Think i'll try a Marshall next time ! :| :| :|
Describe what is wrong....

sparky7083
New Member
Posts: 5
Joined: Mon Apr 23, 2018 7:56 pm

Re: questions not been answered !

Post by sparky7083 » Tue May 19, 2020 8:19 am

I have another orange crush 35 amp......playing fine the night before, when used the next day, there is no sound. I've tried aux input and headphones....still nothing...however to tuner appears to be working ok, so can I assume the signal from the guitar is getting into the amp.
no clicks ,no buz, no nothing, I've asked if this is a common problem an heard anything.
regards
Darren

Jondog
Duke of Orange
Posts: 7144
Joined: Thu Aug 21, 2008 12:16 pm
Location: Ontario, Canada

Re: questions not been answered !

Post by Jondog » Tue May 19, 2020 12:17 pm

sparky7083 wrote:
Tue May 19, 2020 8:19 am
I have another orange crush 35 amp......playing fine the night before, when used the next day, there is no sound. I've tried aux input and headphones....still nothing...however to tuner appears to be working ok, so can I assume the signal from the guitar is getting into the amp.
no clicks ,no buz, no nothing, I've asked if this is a common problem an heard anything.
regards
Darren
Doesn't sound like a common problem and not one that can be diagnosed without having the amp circuitry inspected and tested with proper tools. Could be anything from a bad component to a bad solder/terminal connection. We know it's not a fuse on the power, or tubes...
Image

bclaire
Forum Moderator
Posts: 17739
Joined: Thu May 02, 2002 9:19 pm
Location: Outside Boston MA, USA
Contact:

Re: questions not been answered !

Post by bclaire » Wed May 20, 2020 10:57 am

Check for a fuse. Maybe replace the fuse even if it looks OK.

Then check for anything loose.

Make sure it's not plugged in when you do this.

Don't randomly touch anything, use a pencil to insulate yourself from voltages in caps.

adkguy07
Rocker
Posts: 239
Joined: Tue Sep 27, 2016 3:46 pm
Location: Upstate New York

Re: questions not been answered !

Post by adkguy07 » Thu May 28, 2020 2:29 pm

I had this happen with an Orange Dark Terror. it turned out that my vendor found a fuse blew taking a tube or two out. They fixed it, but since the tubes were past warranty, I had to spend more than I wanted to in getting it fixed. Today the amp works just fine. If your amp is new and under warranty, contact the vendor you purchased it from and see what they recommend.

I can understand that some manufacturers may be reluctant to volunteer providing schematics and
certain kinds of information to the owners of their products; from the standpoint of liability resulting in unqualified owners trying to make repairs that they are not really qualified to perform.

Adkguy07

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 19 guests