Orange amp problems

Orange Amps General Forum

Moderator: bclaire

Post Reply
Evantar
New Member
Posts: 1
Joined: Fri Oct 25, 2019 7:43 am
Location: Clifton

Orange amp problems

Post by Evantar » Fri Oct 25, 2019 12:17 pm

I recently bought an Orange AD30 head, and so far I love it. I took the advice of lots of people and bought new tubes for it, the tubes that came in it were golden dragons or something. I got new EH power and pre-amp tubes.

It sounded great until the other day I was playing at home and volume and gain just would decrease dramatically, then kind of come back in. It would kind of dip in and out. So first I put the old preamp tubes back in and it still did it, so I change the power tubes back to the old ones and I played for about an hour and it didn't do it and I had a gig the next night and then last night and it was fine but I just played again at home and it did it again with the old tubes in it. Also it has only done it at home, nowhere else.

Does anyone have any idea what the problem could be?

Mr Mustard
Tiny Terror
Posts: 56
Joined: Sun May 09, 2004 11:52 pm

Re: Orange amp problems

Post by Mr Mustard » Fri Oct 25, 2019 2:30 pm

My AD15 had a cold solder joint that was causing a similar problem.
Mr. Mustard

LD50
Tiny Terror
Posts: 98
Joined: Thu May 19, 2016 8:35 pm

Re: Orange amp problems

Post by LD50 » Fri Oct 25, 2019 8:24 pm

The suggestion by Mr Mustard is a good one.

Intermittent faults are a pain.

Typically open the amp up (taking all the usual precautions re live wires, charged filter caps etc) set it some where safe and stable and play it (or get someone else to) whilst you use a chopstick (non-conductive and several inches long) to tap connections and wires to see if you can provoke the fault.

Of course if under warranty take it to your dealer for help.

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests