new guy with rockerverb question.

Orange Amps General Forum

Moderator: bclaire

Post Reply
moonman079
New Member
Posts: 2
Joined: Thu Oct 10, 2019 2:01 am

new guy with rockerverb question.

Post by moonman079 » Thu Oct 10, 2019 2:08 am

Hi guys how’s it going? I just got my first orange amp in years. A rockerverb 50mkI 2x12 combo. I had the 100 watt head and 2x12 cab years ago. I liked it a lot so far I like the 50 watt combo as well.
But am having a hard time dialing in my tone. The amp sounds like there is a blanket over it no matter what. The clean is worse than the dirty channel. It’s pretty bad so I was wondering if anyone had any suggestions on anything I could try to open it up?

Boy_Narf
Orange Master
Posts: 2430
Joined: Fri Sep 05, 2008 6:27 am
Location: Canada
Contact:

Re: new guy with rockerverb question.

Post by Boy_Narf » Thu Oct 10, 2019 3:54 am

Hey,

I'm assuming it's used? I would check the bias first. Might have been set cooler by a previous owner with could be causing the duller tone. If it's within range, perhaps a full retube is in order.

Also check the speaker wiring. I've run into a few orange cabs that sound awful. One of which was due to incorrect speaker wiring, the other is still a mystery.

Also if you have a different can to test it with you will at least know if it's the head or cab causing the darkness.

What amp are you coming from? Orange amps are very dark sounding. Could just be you are used to a brighter amp.

If all else fails try an eq pedal in the loop to add top end.

It's got v30s right?

Good luck!
TT | R30 | R30C | PPC212V

PedalTrain2 | Zuma

GLXD16 | Decimate | FlashBackMini | ST1 | TimeLine | BlueSky | RangIII | DMC3XL | EX-50

www.scratchbuffalo.com
www.soundcloud.com/modestnews

Les Paul Lover
Duke of Orange
Posts: 6760
Joined: Tue Aug 18, 2009 9:08 am
Location: Derby, England

Re: new guy with rockerverb question.

Post by Les Paul Lover » Thu Oct 10, 2019 8:47 am

My bet is that it needs new power valves.

However, that doesn't guaranty the improvement you'd like to see, but worn out valves will sound bland, with little sparkle and muffled undefined low end.

Did you plug the combo into an extension cab too? Your R100 was a head + cab, perhaps you prefer PPC rather than an open back combo too.
Ant

Orange Gear: RV50 MKI, R30, AD15, AD5, PPC212
Past Orange: Orange AD30TC Combo, Tiny Terror

Guitars: Gibson Les Paul Standard Faded, Vigier Expert Retro 54, Gibson SG 70s Tribute, Aria Pro II RS X80, G&L ASAT Special Tribute

moonman079
New Member
Posts: 2
Joined: Thu Oct 10, 2019 2:01 am

Re: new guy with rockerverb question.

Post by moonman079 » Fri Oct 11, 2019 2:51 am

I had new tubes put in about a month ago when I got it. I have read a few things online where people seemed to have the same problem. Apparently it’s something with how the mkI’s clean is eq’d.
I have noticed that the combo is not much bigger than the orange 2x12 cab I used to have.
It’s almost like the cabinet is a little
Too small for everything to be squished in there.

Les Paul Lover
Duke of Orange
Posts: 6760
Joined: Tue Aug 18, 2009 9:08 am
Location: Derby, England

Re: new guy with rockerverb question.

Post by Les Paul Lover » Fri Oct 11, 2019 10:36 am

Ok, so beside biasing, there isn't much to do.

What valves did you put in?
I find a JJ ECC83s in V1 would rob the clean channel of its sparkle.

I usually set my clean with bass to 1 o'clock and treble to 2 to 3 o'clock. Love it!!!!
Ant

Orange Gear: RV50 MKI, R30, AD15, AD5, PPC212
Past Orange: Orange AD30TC Combo, Tiny Terror

Guitars: Gibson Les Paul Standard Faded, Vigier Expert Retro 54, Gibson SG 70s Tribute, Aria Pro II RS X80, G&L ASAT Special Tribute

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests