Orange crush has this static sound when i turn it on

Orange Amps General Forum

Moderator: bclaire

Post Reply
bandudut14
New Member
Posts: 1
Joined: Sat Jan 13, 2018 12:54 pm

Orange crush has this static sound when i turn it on

Post by bandudut14 » Sat Jan 13, 2018 1:05 pm

what could be the problem?
checked the cord but is not it
when i pull the cord out and left the amp on and turned the volume up to quarter it has this static sound even on clean tone and worst on overdrive .... please help :(

Les Paul Lover
Duke of Orange
Posts: 6235
Joined: Tue Aug 18, 2009 9:08 am
Location: Derby, England

Re: Orange crush has this static sound when i turn it on

Post by Les Paul Lover » Sat Jan 13, 2018 2:22 pm

How long have you had the amp for? Is it still under warranty?

It sounds like a ground problem, but that could come from a variety of problems. Some components if damaged, could introduce unwanted noise too.
Ant

Orange Gear: RV50 MKI, R30, AD15, PPC212
Past Orange: Orange AD30TC Combo, AD15, Tiny Terror, AD5

Guitars: Gibson Les Paul Standard Faded, Vigier Expert Retro 54, Gibson SG 70s Tribute, Aria Pro II RS X80, G&L ASAT Special Tribute

Rlw59
Rocker
Posts: 212
Joined: Sun Oct 15, 2017 3:31 pm
Location: DFW, Texas, USA

Re: Orange crush has this static sound when i turn it on

Post by Rlw59 » Sat Jan 13, 2018 2:54 pm

Details always help.

Which Crush is it?

Is this a new problem or has it always done it?

Could you post a video or soundclip so we can hear the noise? ("Static" means different things to different people. Is it hissing? Crackling? Snapping? Popping? Humming? Buzzing?)

Rlw59
Rocker
Posts: 212
Joined: Sun Oct 15, 2017 3:31 pm
Location: DFW, Texas, USA

Re: Orange crush has this static sound when i turn it on

Post by Rlw59 » Sat Jan 13, 2018 3:07 pm

Indulge me with a quick easy diagnostic test. Plug in your guitar, and turn the guitar's volume to zero.

Is the noise still there? If so, does it change at all?

Rlw59
Rocker
Posts: 212
Joined: Sun Oct 15, 2017 3:31 pm
Location: DFW, Texas, USA

Re: Orange crush has this static sound when i turn it on

Post by Rlw59 » Sat Jan 13, 2018 3:12 pm

Does the amp have an effects loop?

If so, plug a cord into the send jack and plug the other end into the return jack.

Noise still there? And if so, does it change at all?

Next, plug your guitar directly into the loop return jack. Noise still there? Any change?

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 28 guests