Scared. Ran wrong impedance with Rockerverb 50 head.

Orange Amps General Forum

Moderator: bclaire

Post Reply
Sethery
Orange Hero
Posts: 386
Joined: Fri Jan 18, 2008 2:11 am
Location: USA

Scared. Ran wrong impedance with Rockerverb 50 head.

Post by Sethery » Tue Aug 16, 2011 4:57 am

Last night my band had a gig with gear already set up for us to use, but i wanted to use my rockerverb. They had marshall jcm cabs that im unfamiliar with. Basically i set the cab to mono and plugged it into the 16 ohm jack with the 16 ohm out of my amp, turned it on, and no sound came out at all. I did the same thing again with the switch flipped to stereo and no sound came out again. I ran the amp for probably a minute total with volume levels set about half way up.

THEN i finally got it to work by switching the cab to stereo at 8 ohms with my amp out at 8 ohms and it was all good.

I guess my question simply is, was there damage that could have been done to my amp, and if so, what could have been damaged? Also, i know the amp worked fine after i figured out how to run this thing with the marshall cab, but is there anything that could have been "slightly damaged" that i won't know about unless a tech digs into it?

My life revolves around my orange, i just wanna know what's up. THANK YOU!!
Love, Seth.
Orange PPC-212
Mesa Boogie Tremoverb dual rectifier
Rockerverb50H
PRS Custom 22 ten-top
Ibanez "law suit" Les Paul
Ibanez Jet King
Lots of Pedals (Gonkulator Ring Modulator is my favorite)
http://www.myspace.com/sethsoloproject
http://www.flickr.com/photos/27795172@N05/

Image

Neiloler
Lord of Orange
Posts: 13310
Joined: Wed Mar 22, 2006 12:06 am
Location: USA

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by Neiloler » Tue Aug 16, 2011 5:53 am

If it still sounds the same, you should be fine. Little do most people know, but most transformers can take a bit of mismatch and abuse, but you don't want to try it out. Orange doesn't want to replace a bunch of stuff, so they say "absolutely no mismatches!", so that if it does happen to blow up, which could concievably happen, they're not on the hook for it. Don't try this at home kids. (I have to say that so I'm not on the hook for it ;) )

It sounds like the marshall cab has a crummy switch, I'd look into that a bit more.

jason41224
Orange Master
Posts: 3683
Joined: Fri Jul 16, 2010 2:50 am

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by jason41224 » Tue Aug 16, 2011 6:08 am

what neil said, plus if your tranformers were fried you would smell it.
Image
Jason
Rocker 30
too many pedals

the gray area
Tiny Terror
Posts: 92
Joined: Fri May 13, 2011 11:36 am
Location: UK

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by the gray area » Tue Aug 16, 2011 8:17 am

As above, if its still working ok it's probably fine. A friend kindly set up my DT for me recently before a rehearsal & forgot to attach a speaker lead AT ALL! he did leave it on to warm up in standby though. I freaked a bit but everything seems to be working fine.

ironlung40
Orange Master
Posts: 2844
Joined: Tue Jul 07, 2009 2:10 pm
Location: USA (in the south)

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by ironlung40 » Tue Aug 16, 2011 10:50 pm

the gray area wrote:As above, if its still working ok it's probably fine. A friend kindly set up my DT for me recently before a rehearsal & forgot to attach a speaker lead AT ALL! he did leave it on to warm up in standby though. I freaked a bit but everything seems to be working fine.

I think the amps are o.k. without a load in standby.
Sincerely,
Ironlung40
OR120 Pix
Tiny Terror HW
Rocker 30 combo
Gibson SG 61'--Gibson RD Standard--Gibson SG Special 67'
Image

Randy Bass
Lord of Orange
Posts: 10149
Joined: Tue Sep 29, 2009 3:44 am

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by Randy Bass » Wed Aug 17, 2011 1:48 am

It seems like I was just reading about this somewhere else...
_________________
Image

David Verb
Rocker
Posts: 213
Joined: Wed Aug 25, 2010 1:39 am

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by David Verb » Wed Aug 17, 2011 4:16 am

ironlung40 wrote:
the gray area wrote:As above, if its still working ok it's probably fine. A friend kindly set up my DT for me recently before a rehearsal & forgot to attach a speaker lead AT ALL! he did leave it on to warm up in standby though. I freaked a bit but everything seems to be working fine.

I think the amps are o.k. without a load in standby.
Can someone confirm this? It would be good to know.
Amp
Orange Rockerverb 100

Cabinet
PPC 412 HP 8

jason41224
Orange Master
Posts: 3683
Joined: Fri Jul 16, 2010 2:50 am

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by jason41224 » Wed Aug 17, 2011 7:00 am

pretty sure i read that in a past thread too...
Image
Jason
Rocker 30
too many pedals

sizzlingbadger
Orange Hero
Posts: 369
Joined: Thu Jul 14, 2011 9:13 am
Location: New Zealand
Contact:

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by sizzlingbadger » Wed Aug 17, 2011 7:38 am

No load in standby is fine as there is no HT on the output transformer. (not all amps are like this though, Blackstar HT-40 for instance)

Bensen
Orange Master
Posts: 1165
Joined: Fri Dec 12, 2008 3:29 pm
Location: Germany

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by Bensen » Wed Aug 17, 2011 9:45 am

I ran my AD30 for a year on 8ohm because it said 8ohm on both speakers :roll:
Finally the rectifier tube broke and the tech told me that it could be because of the mismatch.
Works fine since

ironlung40
Orange Master
Posts: 2844
Joined: Tue Jul 07, 2009 2:10 pm
Location: USA (in the south)

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by ironlung40 » Wed Aug 17, 2011 12:20 pm

sizzlingbadger wrote:No load in standby is fine as there is no HT on the output transformer. (not all amps are like this though, Blackstar HT-40 for instance)

even though this is the case, it's still good practice to always have the correct load on your amp whenever it is in standby anyway, that way you don't mess up and switch it on with no load..........that would be very easy to do.
Sincerely,
Ironlung40
OR120 Pix
Tiny Terror HW
Rocker 30 combo
Gibson SG 61'--Gibson RD Standard--Gibson SG Special 67'
Image

sizzlingbadger
Orange Hero
Posts: 369
Joined: Thu Jul 14, 2011 9:13 am
Location: New Zealand
Contact:

Re: Scared. Ran wrong impedance with Rockerverb 50 head.

Post by sizzlingbadger » Wed Aug 17, 2011 10:31 pm

ironlung40 wrote: even though this is the case, it's still good practice to always have the correct load on your amp whenever it is in standby anyway, that way you don't mess up and switch it on with no load..........that would be very easy to do.
Yes totally agree :!:

Post Reply

Who is online

Users browsing this forum: No registered users and 14 guests