Reverb Tank

Orange Amps General Forum

Moderator: bclaire

Post Reply
timme_v
Orange Hero
Posts: 369
Joined: Sun Sep 23, 2007 5:39 am

Reverb Tank

Post by timme_v » Fri Aug 21, 2009 3:22 am

So my reverb wasn't working and now my amp is away for 4 weeks on repairs because it needs a new reverb tank.. I have an RV50 head. How much am I looking at for this replacement?

I also got him to retube/rebias the amp because I have lots of shows coming up and I don't want to be messing around later.

Orphin
Duke of Orange
Posts: 6624
Joined: Wed Sep 15, 2004 9:04 pm
Location: Sweden

Post by Orphin » Fri Aug 21, 2009 6:57 am

How did you manage to break the reverb tank?
David
I'm speaking out of my a$$. Yours might differ.

timme_v
Orange Hero
Posts: 369
Joined: Sun Sep 23, 2007 5:39 am

Post by timme_v » Fri Aug 21, 2009 7:35 am

no clue.. just turned the amp one day and it was working fine except 0 reverb..

tony_clifton
Orange Master
Posts: 1020
Joined: Fri Jan 30, 2009 2:16 pm
Location: Belgium

Post by tony_clifton » Fri Aug 21, 2009 7:38 am

There are two options - the tube powering the reverb gone bad, which will cost no more than the retube job you already asked for, or there is something wrong with the tank/the circuitry/... and you'll pay for the repair.
Those reverb tanks aren't that expensive (about 40 euro/50 dollar), but things can add up :(.

timme_v
Orange Hero
Posts: 369
Joined: Sun Sep 23, 2007 5:39 am

Post by timme_v » Fri Aug 21, 2009 7:41 am

Oh thats not as bad as I thought it would be..

I was expecting hundreds.. It has already been with a tech for 2 weeks and he has determined that its the reverb tank, so he had to order parts and apparently thats going to take a while.. So hopefully he's right about the tank.

tony_clifton
Orange Master
Posts: 1020
Joined: Fri Jan 30, 2009 2:16 pm
Location: Belgium

Post by tony_clifton » Fri Aug 21, 2009 10:03 am

I don't really know what kind of tank Orange uses, but Fender amps got an accutronics which is connected to the amp with 2 cinch plugs (stereo for some reason). Hope he doesn't charge you with a couple of hours of labour (which is possible on the other hand to isolate the problem, but still...)

Orphin
Duke of Orange
Posts: 6624
Joined: Wed Sep 15, 2004 9:04 pm
Location: Sweden

Post by Orphin » Fri Aug 21, 2009 10:42 am

I'm thinking, do you know that the problem is the tank, 'cause that is the most unlikely problem when the reverb is dead?
David
I'm speaking out of my a$$. Yours might differ.

a.hun
Duke of Orange
Posts: 9738
Joined: Sat Jun 15, 2002 1:05 am
Location: Amsterdam, Hollandland.nl

Post by a.hun » Fri Aug 21, 2009 10:59 am

Orphin wrote:I'm thinking, do you know that the problem is the tank, 'cause that is the most unlikely problem when the reverb is dead?
Not really. There are two very fine wires inside these tanks which are quite easily broken. (One not very heavy knock can often do it.) While it is often possible to repair the break it can sometimes be a real pain in the neck to do:
http://www.thegearpage.net/board/showth ... p?t=341063


Andy.
aNDyH. :wink:

Ever tried to outstare a mirror?

In the bathtub of history the truth is harder to hold than the soap, and much more difficult to find!

timme_v
Orange Hero
Posts: 369
Joined: Sun Sep 23, 2007 5:39 am

Post by timme_v » Sat Aug 22, 2009 3:14 am

I'm just going by what the amp repairer said.

He told me I had to wait another 2 weeks because has to order a correct reverb tank as mine is gone. I have no clue when it comes to fixing amps, so I'm just going by what he says.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 29 guests