buzzing noise (grounding?)

Orange Amps General Forum

Moderator: bclaire

Post Reply
manwithgun
Tiny Terror
Posts: 100
Joined: Wed Nov 29, 2006 2:37 pm
Location: United Kingdom

Post by manwithgun » Tue Feb 17, 2009 5:31 pm

Hey there,

i recently bought a Fender JD (CIJ) telecaster fitted with Dimarzio pickups, the problem is that when i plug it into my Rocker 30 it makes a very loud and annoying buzzing sound which is only remedied when i touch the strip of metal that the knobs and pickup selector switch is on!

Nothing happens when i touch the strings the noise is still there, i think it might be a grounding issue but im not that great at guitar tech!

Any advice would be greatly appreciated thanks

BrianGT
Duke of Orange
Posts: 5307
Joined: Sat Oct 07, 2006 7:55 pm
Location: United Kingdom

Post by BrianGT » Tue Feb 17, 2009 5:40 pm

It sounds like the earthing wire under the bridge plate has come adrift.
Perhaps when the std pickups were changed out to DiMarzio's?

Usually it is just a lead with a bit stripped bare that is gripped by the bridge plate against the body and leads to one of the Vol/Tone pots....an easy enough remedy next time you change your strings.......you can then remove the bridge plate screws and if there is no lead there then you can just add one.
The only down side is that you sometimes have to move the saddle screws to get at the screws holding the bridge to the body.

The lead goes through the same body hole as the bridge pickup to the pot.
BrianGT
http://www.myspace.com/gentlethunderband" onclick="window.open(this.href);return false;

Image

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests